Задать вопрос

Составьте программу, которая заполняет массив а[1 ... 10] случайными целыми числами в диапазоне от - 12 до 12 и выводит на экран количество положительных чисел и их значения

+4
Ответы (1)
  1. 25 мая, 14:59
    0
    Все числа в массиве будут целые. Создадим массив целых чисел от - 12 до 12:

    var a : array [1 ... 10] of integer;

    Еще нам нужно будет создать переменную, в которую мы запишем количество нужных по условию задачи элементов. Оно тоже будет целым:

    col-vo : integer;

    for i:integer≔1 to 10 do

    a[i] ≔ random (24) - 12;

    Максимальное число, которое может создать этот random равно 24. Отнимая от него 12, мы будем получать 12.

    Минимальное число, которое может создать этот random равно 0. Отнимая от него 12, мы будем получать - 12.

    for i:integer≔1 to 10 do

    if (a[i] > 0) then

    begin

    col-vo ≔ col-vo + 1;

    write (a[i]:5);

    end;

    writeln ();

    write ('Всего положительных ', col-vo);
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте программу, которая заполняет массив а[1 ... 10] случайными целыми числами в диапазоне от - 12 до 12 и выводит на экран количество ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
Напишите программу которая заполняет массив а[1 ... 10] случайными целыми числами в диапазоне от 1 до 20 и выводит на экран элементы массива с четными значениями
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Составьте программу которая заполняет массив b 1 ... 8 случайными целыми числами в диапазоне от 1 до 10 и находит количество пар элементов с чётными значениями пример ввода: исходный массив: 10 2 4 1 3 5 7 8 количество пар чётных элементов =
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)