Задать вопрос

проверьте делимость Даны два натуральных числа n и m. Если одно из них делится на другое нацело, выведите 1, иначе выведите любое другое целое число. При решении этой задачи нельзя пользоваться условной инструкцией if и циклами.

+5
Ответы (1)
  1. 24 мая, 20:14
    0
    Т. к. не написан язык, то скину паскаль, потому что на нём обычно учатся.

    Это не задача с информатикса случайно?

    var m, n:integer;

    begin

    read (n, m);

    write ((n mod m) * (m mod n) + 1);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «проверьте делимость Даны два натуральных числа n и m. Если одно из них делится на другое нацело, выведите 1, иначе выведите любое другое ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Даны два натуральных числа n и m. Если одно из них делится на другое нацело, вывести 1, иначе вывести любое другое целое число. Нужно сделать на python.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Для 4 произвольных чисел, введенные с клавиатуры, выведите на экран соответствующие результаты. если разностьпервых двух чисел превышает четвертое, то выведите все четыре числа без изменения.
Ответы (1)
Напишите программу в паскаль для решения следующей задачи: для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты.
Ответы (1)
C++. С клавиатуры вводится любое цело число, если оно чётное, то вывести число 5 иначе любое другое.
Ответы (1)