Задать вопрос

Дано натуральное число n вычислить 1*2+2*3*4 + ... + n * (n+1) * ... * 2n (паскаль, цикл)

+4
Ответы (1)
  1. 7 октября, 16:51
    0
    program cycle_;

    var n: byte;

    s, p: int64;

    begin

    writeln ('Введите число');

    Readln (n);

    s: = 0;

    for i: integer: = 1 to n do

    begin

    p: = 1;

    //цикл для подсчета произведения n * (n + 1) ... 2 * n

    for k: integer: = i to 2 * i do p: = p * k;

    s: = s + p; //сумма произведений

    end;

    writeln (s);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дано натуральное число n вычислить 1*2+2*3*4 + ... + n * (n+1) * ... * 2n (паскаль, цикл) ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дано число а и натуральное число n. Напечатать на экране а в степени n (Паскаль цикл с предусловием)
Ответы (1)
1. Вычислить значение переменной Y при заданном значении N: Y=1/1+1/2+1/3 + ... + 1/N. использовать цикл типа ДО. (Паскаль) 2. Найти все целые двузначные числа, удовлетворящие условию: остаток от деления на 3 равен 2. (Паскаль)
Ответы (1)
1. Дано двузначное число. Найти разность и частное его цифр. 2. Дано целое число. Если оно является положительным то прибавить к нему 1. Емли нулевым то заменить его на 10. 3. Дано двузначное число. Вывести его левую цифру, потом правую. 4.
Ответы (1)
написать программу на языке паскаля 1) Дано натуральное число. Определить является ли оно чётным 2) дано натуральное число. Определить оканчивается ли оно цифрой 7.
Ответы (1)
дано натуральное число n. Вычислить у=1*3*5 ... * (2n-1). Составить программу на языке Паскаль.
Ответы (1)