Задать вопрос
28 декабря, 18:09

Составить программу, которая вычисляет сумму и произведение цифр четырехзначного числа

+3
Ответы (1)
  1. 28 декабря, 18:32
    0
    program zz1;

    var s, n, k, p:integer; / / задаем переменные целого типа

    begin

    write (' введите четырехзначное число ');

    read (n); / / вводим с клавиатуры число

    p:=1; s:=0;

    while n>0 do / / организуем цикл, пока в числе есть цифры

    begin

    k:=n mod 10; / / получаем последнюю цифру

    s:=s + k; / / прибавляем ее к сумме

    p:=p * k; / / умножаем ее на произведение

    n:=n div 10; / / отбрасываем ее

    end;

    writeln ('произведение цифр четырехзначного числа = ', p); / / выводим ответ

    writeln ('сумма цифр четырехзначного числа = ', s);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу, которая вычисляет сумму и произведение цифр четырехзначного числа ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
1) Напишите программу, которая определяет, является ли число нечётным. 2) Напишите программу, которая вычисляет сумму всех чётных чисел в диапазоне от 1 до n.
Ответы (1)
1) Составить программу которая выводит на экран каждое 5-ое число и таких чисел 20.2) Составить программу которая вычисляет произведение натуральных чисел от 5 до 10.
Ответы (1)
С клавиатуры вводят строку, состоящую из латинских букв и цифр. Написать программу, которая вычисляет сумму цифр, попадающихся в этой строке, а также выводящую строку после исключения из неё этих цифр. Для паскаль abc.
Ответы (1)
В паскале Составьте программу, которая для произвольного натурального четырехзначного числа определяет сумму и произведение его цифр.
Ответы (1)