Задать вопрос
7 апреля, 18:59

Найти среднее арифметическое квадратов всех целых чисел от 1 до 100. программа в паскале

+1
Ответы (1)
  1. 7 апреля, 20:08
    0
    program zz1;

    var r, i, k:integer; / / задаем переменные целого типа

    begin

    for i:=1 to 100 do / / организуем цикл, в котором переберем все числа от единицы до ста

    begin r:=r + i * i; k:=k + 1; end; / / добавляем квадрат числа к сумме и считаем количество

    write (' среднее арифметическое квадратов всех целых чисел от 1 до 100 = ', r / k); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Найти среднее арифметическое квадратов всех целых чисел от 1 до 100. программа в паскале ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Найти среднее арифметическое всех положительных целых чисел от a до b (b>=a) Если таких чисел нет то вывести сообщение "Таких чисел нет"Программа на Паскале (net или abc)
Ответы (1)
Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы.
Ответы (1)
Установите соответствие: 1) базовое системное ПО а) операционная система 2) утилиты б) программа диагностики дисков в) антивирусная программа г) операционная оболочка д) программа архивации данных e) программа обслуживания сети
Ответы (1)
Программа в паскале. Даются 3 натуральных числа, если сумма первых двух больше нуля, определите максимальное число, в ином случае вычислите среднее арифметическое.
Ответы (1)
Напишите программу в паскале, которая в последовательности натуральных чисел определяет максимальное число, кратное 4. Программа получает на вход количество чисел в последовательности, а затем сами числа.
Ответы (1)