Задать вопрос
2 ноября, 13:29

Найти среднее арифметическое всех положительных целых чисел от a до b (b>=a) Если таких чисел нет то вывести сообщение "Таких чисел нет"Программа на Паскале (net или abc)

+5
Ответы (1)
  1. 2 ноября, 14:49
    0
    program zz1;

    var a, b, r, i, k:integer; / / задаем переменные целого типа

    begin

    write (' введите первое число '); / / вводим с клавиатуры первое число

    read (a);

    write (' введите второе число '); / / вводим с клавиатуры второе число

    read (b);

    for i:=a to b do

    if i > 0 then begin r:=r + i; k:=k + 1; end; / / проверяем условие, если число из диапазона положительное, то добавляем его к сумме и считаем количество

    if k = 0 then write (' Таких чисел нет ') else write (' среднее арифметическое всех положительных целых чисел от a до b = ', r/k); / /выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Найти среднее арифметическое всех положительных целых чисел от a до b (b>=a) Если таких чисел нет то вывести сообщение "Таких чисел ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Вывести массив A (N). Вывести на печать данные о числе нулевых элементов массива и их номера. Если таковых нет, вывести на печать сообщение об этом 2) Вывести массив А (N, N). Разделить все его элементы на минимальный элемент главной диагонали.
Ответы (1)
Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Найти среднее арифметическое квадратов всех целых чисел от 1 до 100. программа в паскале
Ответы (1)