Задать вопрос
7 сентября, 17:42

Составить программу, которая в тексте удаляет все пробелы.

+2
Ответы (1)
  1. 7 сентября, 20:34
    0
    program zz1;

    var s:string; / / задаем переменную строкового типа

    begin

    write (' введите строку ');

    read (s); / / вводим с клавиатуры строку

    While (Pos (' ', s) 0) do / / организуем цикл, пока в строке есть пробелы

    Begin

    Delete (s, Pos (' ', s), 1); / / определяем позицию пробела в строке с помощью строковой функции Pos и удаляем его с помощью специальной строковой команды Delete

    End;

    write (' полученная строка без пробелов = ', s); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу, которая в тексте удаляет все пробелы. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы