Задать вопрос

Дано число y при вводе с клавиатуры числа x должно вывести ему равен y, если y=1, если х≥1. y=0 если - 1

+5
Ответы (1)
  1. 24 февраля, 09:31
    0
    Program sootnoshenie;

    var x, y: integer;

    begin

    writeln ('введите любое число с клавиатуры');

    readln (x);

    if x > = 1 then

    y : = 0;

    if (x > = - 1) and (x < = 1) then

    y : = 0;

    if x < 0 then

    y : = - 1;

    writeln (y);

    end.

    (Программа работает, проверена в PascalABC)
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дано число y при вводе с клавиатуры числа x должно вывести ему равен y, если y=1, если х≥1. y=0 если - 1 ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Напишите программу которая выводит на экран слово "женский" при вводе символа Ж и словa " мужской" при вводе символа М
Ответы (1)
1) Вывести массив A (N). Вывести на печать данные о числе нулевых элементов массива и их номера. Если таковых нет, вывести на печать сообщение об этом 2) Вывести массив А (N, N). Разделить все его элементы на минимальный элемент главной диагонали.
Ответы (1)
Надо написать программу на Паскале, без массивов. Дано натуральное число. Определить, сколько раз у этого числа встречается минимальная цифра. (Например, при вводе числа 2618319, на экране должно быть "2").
Ответы (1)