Задать вопрос

Придумать программу которая в массиве случайных чисел находит число равное 10. Если такого числа не существует, то на экране должна появиться запись "такого числа не существует".

+4
Ответы (1)
  1. 27 апреля, 22:50
    0
    program zz1;

    const n = 5; / / задаем количество элементов в массиве

    var i, s, k:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    m[i]:=random (21);

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    for i:=1 to n do

    if m[i] = 10 then k:=k + 1;

    if k = 0 then writeln (' такого числа не существует ')

    else writeln (' элементов равных 10 = ', k); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Придумать программу которая в массиве случайных чисел находит число равное 10. Если такого числа не существует, то на экране должна ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Написать программу, которая находит в массиве случайных символов первое вхождение заданного символа.
Ответы (1)
Напишите программу, которая находит в массиве самую длинную цепочку одинаковых элементов. Программа должна вывести значение элемента, который встречается наибольшее число раз подряд, и длину этой цепочки.
Ответы (1)
Дан массив, содержащий 2015 положительных целых чисел. Напишите на одном из языков программирования программу, которая находит в этом массиве количество локальных минимумов, значение которых кратно 3.
Ответы (1)
Составьте программу которая формирует массив из 20 случайных чисел от - 10 до 10 и находит отрицательные элементы
Ответы (1)
1) Напишите программу, которая определяет, является ли число нечётным. 2) Напишите программу, которая вычисляет сумму всех чётных чисел в диапазоне от 1 до n.
Ответы (1)