Задать вопрос

В соревнованиях по прыжкам в длину участвуют 25 спортсменов, с клавиаиуры ввести номер спортсмена и его результат (номер спортсмена не связан с очередностью). Написать программу, которая выводит на экран номер и результат худшего и лучшего спортсменов. все это как то связанно с оператором повтора FOR

+5
Ответы (1)
  1. 28 января, 06:13
    0
    program zz1;

    var a, b, n, i, max, min:integer; / / задаем переменные целого типа

    begin

    max:=0; min:=100000;

    for i:=1 to 25 do

    begin

    write (' введите результат ', i,' - го спортсмена '); / / вводим с клавиатуры число

    read (n);

    if n > max then begin max:=n; b:=i; end; / / проверяем, если число больше максимального, то записываем его в максимальное и запоминаем номер

    if n < min then begin min:=n; b:=i; end; / / проверяем, если число меньше минимального, то записываем его в минимальное и запоминаем номер

    end;

    write (' результат лучшего спортсмена = ', max, ' его номер = ', b); / /выводим ответы

    write (' результат худшего спортсмена = ', min, ' его номер = ', b);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «В соревнованиях по прыжкам в длину участвуют 25 спортсменов, с клавиаиуры ввести номер спортсмена и его результат (номер спортсмена не ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
Ввести 2 числа используя оператор ввода данных read (). Перед оператором read () обязательно вывести объяснения значения какой переменной надо ввести (Например, writeln ('vvedite a'); ). Ввести их через запятую.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Составьте программу которая выводит на экран пример на умножение двух однозначных чисел, запрашивает ответ пользователя. проверяет его и выводит соответсвующиеся сообщения : "Правильно!" либо "Вы ошиблись". а также правильный результат.
Ответы (1)
Написать программу, которая заполняет элементами массив по правилу: а (I) = (i^4/7i-2), выводит его элементы на экран с двумя знаками после запятой и затем выводит новый массив, в котором заменены на противоположные знаки элементов исходного массива.
Ответы (1)