Задать вопрос
12 марта, 11:56

Составьте программу вычисления количества трёхзначных чисел у которых: цифры упорядочены строго по убыванию.

+3
Ответы (1)
  1. 12 марта, 12:12
    0
    program zz1;

    var a, b, r, i, p:integer; / / задаем переменные целого типа

    begin

    for i:=100 to 999 do / / организуем цикл, в котором переберем все трехзначные числа

    begin

    a: = i mod 10; / / получаем третью цифру

    b: = i div 100; / / получаем первую цифру

    r: = (i mod 100) div 10; / / получаем вторую цифру

    if (b > r) and (r > a) then p: = p + 1; / / проверяем цифры на убывание, если строго убывают, то считаем

    end;

    writeln (' количество найденных трехзначных чисел = ', p); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте программу вычисления количества трёхзначных чисел у которых: цифры упорядочены строго по убыванию. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы