Задать вопрос

Составить программу, которая в зависимости от порядкового номера месяца выводит на экран количество дней в этом месяце. Рассмотреть два случая: 1. год високосный. 2. год не является високосным

+2
Ответы (1)
  1. 20 мая, 22:58
    0
    program zz1;

    var s, k:integer; / / задаем переменную строкового типа

    begin

    write (' введите год ');

    read (s); / / вводим с клавиатуры год

    if (s mod 4 0) or (s mod 100 = 0) and (s mod 400 0)

    then

    begin

    writeln (' введите номер месяца ');

    read (k);

    if k = 1 then write ('31 дней');

    if k = 2 then write ('28 дней');

    if k = 3 then write ('31 дней');

    if k = 4 then write ('30 дней');

    if k = 5 then write ('31 дней');

    if k = 6 then write ('30 дней');

    if k = 7 then write ('31 дней');

    if k = 8 then write ('31 дней');

    if k = 9 then write ('30 дней');

    if k = 10 then write ('31 дней');

    if k = 11 then write ('30 дней');

    if k = 12 then write ('31 дней');

    end

    else

    begin

    writeln (' введите номер месяца ');

    read (k);

    if k = 1 then write ('31 дней');

    if k = 2 then write ('28 дней');

    if k = 3 then write ('31 дней');

    if k = 4 then write ('30 дней');

    if k = 5 then write ('31 дней');

    if k = 6 then write ('30 дней');

    if k = 7 then write ('31 дней');

    if k = 8 then write ('31 дней');

    if k = 9 then write ('30 дней');

    if k = 10 then write ('31 дней');

    if k = 11 then write ('30 дней');

    if k = 12 then write ('31 дней');

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу, которая в зависимости от порядкового номера месяца выводит на экран количество дней в этом месяце. Рассмотреть два ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
Ввести номер месяца и вывести количество дней в нем, а также число ошибок при вводе введите номер месяца: - 2 введите номер месяца: 2 введите номер месяца: 11 в этом месяце 28 дней в этом месяце 30 дней Вы вводили неверно 1 раз Вы вводили неверно 1
Ответы (1)
Задача. Год является високосным, если его номер кратен 4, однако из кратных 100 високосными являются лишь кратные 400. Например 1700,1800,1900-не високосные, а 2000 високосный. Дано натуральное число n.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Требуется определить, является ли данный год високосным. (Напомним, что год является високосным, если его номер кратен 4, но не кратен 100, а также если он кратен 400.
Ответы (1)