Задать вопрос

Паскаль. Ввести номер месяца и номер дня, вывести число дней, оставшихся до Нового года

+5
Ответы (1)
  1. 2 декабря, 23:38
    0
    program new_year;

    var sum, month, day:integer;

    const d: array [1 ... 12] of integer = (31,28,31,30,31,30,31,31,30,31,30,31);

    //массив дней в месяцах задан как константа

    begin

    writeln ('Введите номер месяца и номер дня через пробел');

    readln (month, day);

    sum:=0;

    for i:integer: = month to 12 do sum:=sum+d[i];

    //сумма дней до конца года

    //за текущий и последующие месяцы

    sum:=sum - day; / /вычесть дни с начала месяца

    write ('До Нового года осталось ', sum,' дней');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Паскаль. Ввести номер месяца и номер дня, вывести число дней, оставшихся до Нового года ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Ввести номер месяца и вывести количество дней в нем, а также число ошибок при вводе введите номер месяца: - 2 введите номер месяца: 2 введите номер месяца: 11 в этом месяце 28 дней в этом месяце 30 дней Вы вводили неверно 1 раз Вы вводили неверно 1
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Ввести номер месяца и вывести название времени года. Пример: Введите номер месяца 4 веснаНапишите программу на языке паскаль
Ответы (1)
ввести 3 стороны треугольника, вывести его площадь. (на языке паскаль) ввести число, вывести квалратный корень.
Ответы (1)
Ввести число от 5 до 9. Вывести его значение словом. Составить программу для решения приведенного ниже задания двумя способами, используя: а) команду выбора case; б) команду if. Ввести число от 5 до 9. Вывести его значение словом.
Ответы (1)