Задать вопрос
9 апреля, 07:09

Составьте программу, которая находит сумму нечетных чисел и произведение четных чисел в диапазоне от 20 до 35.

+2
Ответы (1)
  1. 9 апреля, 08:50
    0
    Составляем цикл

    Переменная от 20 до 35 for i:=1 to 10 do

    Далее проверяем деление чисел на 2 (четные)

    Складываем их и выводим ответ, если не делится на 2, то умножаем нечетные числа и выводим ответ.

    Используем условия If, else, then

    Составим программу на языке программирования Pascal

    var a, b, i:integer;

    begin

    a:=0;

    b:=1;

    for i:=20 to 35 do

    if i mod 2=0 then a:=a+i else b:=B*i;

    write (a,' ', b)

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте программу, которая находит сумму нечетных чисел и произведение четных чисел в диапазоне от 20 до 35. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Составьте программу, которая находит сумму четных чисел и произведение нечётных чисел в диапазоне от 1 до 10
Ответы (1)
1) Напишите программу, которая определяет, является ли число нечётным. 2) Напишите программу, которая вычисляет сумму всех чётных чисел в диапазоне от 1 до n.
Ответы (1)
Составьте программу которая заполняет массив b 1 ... 8 случайными целыми числами в диапазоне от 1 до 10 и находит количество пар элементов с чётными значениями пример ввода: исходный массив: 10 2 4 1 3 5 7 8 количество пар чётных элементов =
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов2) Дан массив целых чисел.
Ответы (1)
1. Составить программу ввода элементов массива A[1 ... 12]случайными целыми числами в диапазоне от - 10 до 10 и находит количество элементов с отрицательными значениями. 2. Составить программу ввода элементов массива A[1 ...
Ответы (1)