Задать вопрос

Составьте программу, которая находит сумму четных чисел и произведение нечётных чисел в диапазоне от 1 до 10

+1
Ответы (1)
  1. 18 января, 06:08
    0
    var a : = array[1 ... 10] of integer;

    i: integer;

    sch, snch: integer;

    begin

    writeln ('Заполняем массив числами от 1 до 10');

    for i : = 1 to 10 do a[i] : = i;

    writeln ('Ищем сумму чётных элементов');

    for i : = 1 to 10 do if a[i] mod 2 = 0 then sch : = sch + a[i];

    writeln ('Ищем сумму нечётных элементов');

    for i : = 1 to 10 do if a[i] mod 2 > 0 then snch : = snch + a[i];

    writeln ('Сумма чётных элементов равна', sch);

    writeln ('Сумма нечётных элементов равна', snch);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте программу, которая находит сумму четных чисел и произведение нечётных чисел в диапазоне от 1 до 10 ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Составьте программу, которая находит сумму нечетных чисел и произведение четных чисел в диапазоне от 20 до 35.
Ответы (1)
1) Напишите программу, которая определяет, является ли число нечётным. 2) Напишите программу, которая вычисляет сумму всех чётных чисел в диапазоне от 1 до n.
Ответы (1)
Составьте программу которая заполняет массив b 1 ... 8 случайными целыми числами в диапазоне от 1 до 10 и находит количество пар элементов с чётными значениями пример ввода: исходный массив: 10 2 4 1 3 5 7 8 количество пар чётных элементов =
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов2) Дан массив целых чисел.
Ответы (1)
1. Составить программу ввода элементов массива A[1 ... 12]случайными целыми числами в диапазоне от - 10 до 10 и находит количество элементов с отрицательными значениями. 2. Составить программу ввода элементов массива A[1 ...
Ответы (1)