Задать вопрос

Напишите программу в паскале, которая вводит два целых числа и находит их произведение, не используя операцию умножения. Учтите, что числа могут быть отрицательными.

+1
Ответы (1)
  1. 4 апреля, 08:32
    0
    program produkt;

    var a, b, p: integer;

    begin

    p: = 0;

    writeln ('Введите два множителя через пробел');

    readln (a, b);

    //Если оба числа положительны или оба отрицательны, то операцию умножения

    //можно заменить многократным добавлением модуля одного из чисел.

    //Если одно число отрицательно, другое положительно,

    //то умножение можно заменить многократным вычитанием модуля одного из чисел.

    if ((a > 0) and (b > 0)) or ((a < 0) and (b < 0)) then

    for i:integer: = 1 to abs (b) do p: = p + abs (a)

    else for i:integer: = 1 to abs (b) do p: = p - abs (a);

    writeln ('Произведение: ', p)

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите программу в паскале, которая вводит два целых числа и находит их произведение, не используя операцию умножения. Учтите, что числа ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы