Задать вопрос

Напишите программу которая вводит натуральное число N и находит все совершенные числа в диапазоне от 1 до Npascal

+3
Ответы (1)
  1. 2 марта, 02:22
    0
    Var i, j, n, p: integer;

    begin

    readln (n);

    for i : = 1 to n do

    begin

    p : = 0;

    for j : = i - 1 downto 1 do

    if (i mod j = 0) then p : = p + j;

    if p = i then writeln (i, ' - совершенное число');

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите программу которая вводит натуральное число N и находит все совершенные числа в диапазоне от 1 до Npascal ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
1) Напишите программу, которая определяет, является ли число нечётным. 2) Напишите программу, которая вычисляет сумму всех чётных чисел в диапазоне от 1 до n.
Ответы (1)
Напишите программу, которая вводит натуральные числа a и b и выводит все простые числа в диапазоне от a до b. Входные данные: Входная строка содержит два натуральных числа, a и b. Гарантируется, что a ≤ b.
Ответы (1)
1. Составить программу ввода элементов массива A[1 ... 12]случайными целыми числами в диапазоне от - 10 до 10 и находит количество элементов с отрицательными значениями. 2. Составить программу ввода элементов массива A[1 ...
Ответы (1)
Напишите программу в паскале, которая вводит два целых числа и находит их произведение, не используя операцию умножения. Учтите, что числа могут быть отрицательными.
Ответы (1)