Задать вопрос

Вводится количество занятий (часов) по предмету и количество пропущенных занятий. Вычислить процент посещаемости. составьте программу паскаль

+5
Ответы (1)
  1. 28 февраля, 09:21
    0
    program zz1;

    var a, b:integer; / / задаем переменные целого типа

    n:real; / / задаем переменную не целого типа

    begin

    write (' введите количество занятий по предмету '); / / вводим с клавиатуры одно число

    read (a);

    write (' введите количество пропущенных занятий по предмету '); / / вводим с клавиатуры другое число

    read (b);

    n:=b * 100 / a; / / высчитываем процент посещаемости по формуле

    write (' процент посещаемости = ', n:6:2, ' %'); / /выводим ответ в формате шесть знаков для всего числа и два знака после точки

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Вводится количество занятий (часов) по предмету и количество пропущенных занятий. Вычислить процент посещаемости. составьте программу ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Написать в Паскаль программу для решения следующей задачи. Вводится строка. Написать пользовательскую функцию, которая возвращает строку 'DA', если количество символов в ней двухзначное число и возвращает 'NET', если количество символов однозначное
Ответы (1)
1) Написать программу на языке Паскаль, которая вычисляет среднее арифметическое пяти любых чисел. 2) Написать программу на языке Паскаль, вычисляющую корни квадратного уравнения.
Ответы (1)
Вводится текущее время. написать программу, определяющую это время до полудня или после. На языке паскаль.
Ответы (1)
Написать в Паскаль программу для решения следующей задачи. Вводится строка, состоящая только из цифр без нуля. Написать пользовательскую функцию, которая возвращает строку, добавляя после каждого символа символ '0'.
Ответы (1)
Составить программу, которая вычисляет среднее арифметическое чисел. введенных с клавиатуры. Ввод чисел заканчивается, когда вводится 0. (на языке Паскаль)
Ответы (1)