Задать вопрос
26 февраля, 18:11

Составить алгоритм и программу для решения задачи найдите длину окружности L и площадь круга S если известно что его радиус равен R

+4
Ответы (1)
  1. 26 февраля, 20:14
    0
    program zz1;

    var r, L, s:real; / /задаем переменные не целого типа

    begin

    write ('введите исходное значение радиуса окружности '); / /вводим с клавиатуры исходное значение r

    read (r);

    s: = pi * r * r; / / вычисляем площадь круга по формуле

    writeln ('полученное значение площади круга = ', s:5:2); / /выводим ответ в формате пять знаков для всего числа и два знака после запятой

    L:=2 * pi * r; / / вычисляем длину окружности по формуле

    write ('полученное значение длины окружности = ', L:5:2); / /выводим ответ в формате пять знаков для всего числа и два знака после запятой

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить алгоритм и программу для решения задачи найдите длину окружности L и площадь круга S если известно что его радиус равен R ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Что такое алгоритм? Зачем люди составляют и исполняют алгоритм. Какими разными способами можно описать способ решения задач? Как называют наглядную модель процесса решения задач? Какой алгоритм можно назвать линейным?
Ответы (1)
Составить программу для решения следующей задачи: Найти площадь кольца, если заданы радиус внешней окружности и радиус внутренней окружности.
Ответы (1)
Написать программу в паскале! Написать программу при помощи процедуры, которая по известному радиусу возвращает в основную программу значения площади круга и длины окружности.
Ответы (1)
Составьте программу решающую следующую задачу. Известна длина окружности L. Найдите площадь круга S ограниченного этой окружностью. Формулы для вычисления длины окружности и площади круга I=2 пR? S = пR^2 (где п = 3,14)
Ответы (1)
Разработать алгоритм для ввода четырёх целых чисел и вычисление их среднего арифметического. Протестировать алгоритм на исходных данных: - 5,8,-1,9. Линейный алгоритм
Ответы (1)