Задать вопрос

В массиве из 12 целых положительных чисел от 0 до 20 поменять местами первый и последний элементы, второй и предпоследний, и т. д ... Вывести исходный и полученный массивы, ABC Paskal

+1
Ответы (1)
  1. 3 июня, 16:29
    0
    program zz1;

    const n = 12; / / задаем количество элементов в массиве

    var i, t:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    m[i]:=random (21);

    for i:=1 to n do / / выводим исходный массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    for i:=1 to n div 2 do

    swap (m[i], m[n - i + 1]); / / меняем местами

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «В массиве из 12 целых положительных чисел от 0 до 20 поменять местами первый и последний элементы, второй и предпоследний, и т. д ... ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) Вывести массив A (N). Вывести на печать данные о числе нулевых элементов массива и их номера. Если таковых нет, вывести на печать сообщение об этом 2) Вывести массив А (N, N). Разделить все его элементы на минимальный элемент главной диагонали.
Ответы (1)
В массиве все положительные элементы увеличить в 2 раза, а все отрицательные заменить на 7. Вывести на экран исходный и преобразованный массивы.
Ответы (1)
Дан массив целых чисел. Поменять местами первый максимальный (если таковых несколько) и последний минимальный (если таковых несколько) по значению элементы массива. Число элементов в массиве не более 10-ти Pascal
Ответы (1)
Составьте программу, которая заполняет массив а[1 ... 10] случайными целыми числами в диапозоне от 0 до 10, затем первый элемент меняет местами с максимальным элементом. Выведите на экран исходный и полученный массивы.
Ответы (1)