Задать вопрос

Написать программу в которой задано целое число n и выводится каждая его цифра в столбец. На ABC. Pascal

+1
Ответы (1)
  1. 21 февраля, 22:23
    0
    program zz1;

    var n, k:integer; / / задаем переменные целого типа

    begin

    write (' введите любое число ');

    read (n); / / вводим с клавиатуры число

    while n>0 do / / организуем цикл, пока в заданном числе есть цифры

    begin

    k:=n mod 10; / / получаем последнюю цифру, разделив число на десять и взяв от деления остаток

    writeln (k); / / выводим полученную цифру на экран в столбец

    n:=n div 10; / / отбрасываем ее из исходного числа, разделив число на десять и взяв от деления целую часть

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу в которой задано целое число n и выводится каждая его цифра в столбец. На ABC. Pascal ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Требовалось написать программу, при выполнении которой с клавиатуры вводится натуральное число, не превосходящее 10^8, и выводится его первая цифра.
Ответы (1)
1) Дана матрица размером M * N. В каждой строке матрицы найти минимальный элемент и максимальный из найденного. 2) дана матрица размерами N * N. Поменять местами столбец с максимальным и столбец содержащий минимальное количество нулевых элементов.
Ответы (1)
Написать программу на языке Pascal Задано произвольное число. Проверить является ли оно четным.
Ответы (1)
Дано целое неотрицательное число N, определите число десятков в нем (предпоследнюю цифру числа). Если предпосленей цифры нет, то можно считать, что число десятков равно нулю. (Напишите программу для решения в Pascal. ABC)
Ответы (1)
Написать программу, которая принимает на вход двухзначное число, а выводит на экран число, у которого цифры меняются местами. Например, вводится число 37, а выводится 73. Подсказка: используйте операторы div и mod.
Ответы (1)