Задать вопрос

Составить программу выводящую на экран все делители на число х. (число х вводится с клавиатуры)

+1
Ответы (1)
  1. 17 августа, 17:12
    0
    prog poi; / название программы, может быть любое, в каких то версиях ставится само;

    var x, del : integer; / переменные целого типа;

    begin / тело программы;

    write ('Введите x : '); / просим ввести пользователя значение числа х;

    readln (x); / ввод числа;

    write ('Делители : '); / делители;

    for del : = 1 to x do / цикл в котром выбираются делители;

    if (x mod del) = 0 then

    write (del, ' '); / выводим делители на экран;

    writeln;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу выводящую на экран все делители на число х. (число х вводится с клавиатуры) ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1). Составить программу, которая выводит на экран сумму, произведение и средние арифметическое кубов всех целых чисел от a до, b. (Значение переменных a и b вводится с клавиатуры). 2).
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Напечатать "столбиком": а) все целые числа от 20 до 35; б) квадраты всех целых чисел от 10 до b (значение b вводится с клавиатуры; b > (или равно) 10); в) третьи степени всех целых чисел от a до 50 (значение а вводится с клавиатуры; а (или равно) а).
Ответы (1)
С клавиатуры вводятся два числа. Составить программу сравнивающую эти числа и в зависимости от результата сравнения выводящую на экран нужный знак. Например: 32.
Ответы (1)
А) Составьте, программу выводящую на экран все делители натурального числа N
Ответы (1)