Задать вопрос

Написать программу, которая выводит функцию У = модуль Х, диапазон от 1 до 4, шаг превращения 0,5

+3
Ответы (1)
  1. var y: array[1 ... 4] of integer; / /Заводим переменную для y. Для удобства сделаем массив.

    x: byte; / /Заводим переменную для x.

    i: integer; / /Заводим переменную для i.

    begin / /Начало.

    x : = 0.5; / /Диапазон от 1. Начальное значение сделаем чуть меньше - сразу увеличится в цикле.

    while x < 4 do begin / /Код исполняется, пока x < 4.

    i : = i + 1; / /Индекс для массива y.

    x : = x + 0.5; / /Шаг превращения 0.5.

    y[i] : = sqrt (sqr (x)); / /Заносим в массив модуль числа x.

    end; / /Конец цикла.

    for i : = 1 to x do writeln (y[i]); / /Выводим рассчитанные значения функции.

    end. / /Конец программы.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу, которая выводит функцию У = модуль Х, диапазон от 1 до 4, шаг превращения 0,5 ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
Написать программу, которая заполняет элементами массив по правилу: а (I) = (i^4/7i-2), выводит его элементы на экран с двумя знаками после запятой и затем выводит новый массив, в котором заменены на противоположные знаки элементов исходного массива.
Ответы (1)
Написать программу на языке Pascal. Написать программу, которая выводит 10 одинаковых чисел
Ответы (1)
Напишите программу которая для числа выводит значение тригонометрических функцийю sin и cos например вводим 180 программа выводит sin (180) = 0 и cos (180) = -1
Ответы (1)
Составьте программу которая выводит на экран пример на умножение двух однозначных чисел, запрашивает ответ пользователя. проверяет его и выводит соответсвующиеся сообщения : "Правильно!" либо "Вы ошиблись". а также правильный результат.
Ответы (1)
 
Войти
Задать вопрос