Задать вопрос

Напечатать все двузначные числа сумма которых равна 12 (Делать через турбо паскаль)

+2
Ответы (1)
  1. 11 июня, 17:40
    0
    program zz1;

    var k, s, i:integer; / / задаем переменные целого типа

    begin

    for i:=10 to 99 do / / организуем цикл, в котором переберем все двузначные числа

    begin

    s:=i mod 10; / / получаем последнюю цифру двузначного числа

    k:=i div 10; / / получаем первую цифру двузначного числа

    if s + k = 12 / / проверяем условие, если сумма первой и второй цифр двузначного числа равны двенадцати, то

    then write (i, ' '); / / выводим ответ в строчку через пробел

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напечатать все двузначные числа сумма которых равна 12 (Делать через турбо паскаль) ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Составьте программу для нахождения минимального элемента массива Х, состоя - щего из 6 элементов, значения которых рассчитываются по формуле X = (sini-1) / 2cosi+1 Язык Турбо Паскаль
Ответы (1)
Даны два числа А и В. Найти наибольшее из них и вывести его на экран. Cоставить программу для Турбо Паскаль.
Ответы (1)
Ввести с клавиатуры 10 целых чисел. Подсчитать количество нечётных (в паскаль турбо)
Ответы (1)
1. Вычислить значение переменной Y при заданном значении N: Y=1/1+1/2+1/3 + ... + 1/N. использовать цикл типа ДО. (Паскаль) 2. Найти все целые двузначные числа, удовлетворящие условию: остаток от деления на 3 равен 2. (Паскаль)
Ответы (1)
1. Дан массив натуральных чисел. Напечатать все элементы массива, являющиеся двузначными числами. 2. Дан массив. Напечатать четные элементы. 3. Все элементы массива с четными номерами удвоить, с нечетными - уменьшить на 1.
Ответы (1)