Задать вопрос

Напишите программу, которая принимает число, а на выходе возвращает ноль, если число четное и само число, если оно нечетное. Pascal

+3
Ответы (1)
  1. 30 июня, 09:04
    0
    Program chislo;

    Var

    a:integer;

    Begin

    writeln ('Введите число'); {Вывод на экран фразы 'Введите число'}

    readln (a); {Считывание с клавиатуры числа а}

    if a mod 2=0 then writeln (0) {Если остаток от деления числа на 2 равен нулю, то на экран выводиться число 0}

    else {Иначе, т. е. если условие о делении не выполняется}

    writeln (a); {Вывод на экран числа а}

    end.

    {} - В языке программирования Pascal - 'комментарий'. Текст, записанный внутри фигурных скобок не считывается компьютером.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите программу, которая принимает число, а на выходе возвращает ноль, если число четное и само число, если оно нечетное. Pascal ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Установите взаимно-однозначное соответствие между функциями и их действием: 1) Возвращает значение, следующее за х а) chr (x) 2) Возвращает значение, предшествующее х б) pred (x) 3) Возвращает символ с кодом х, где х - целое число от 0 до 255 в)
Ответы (1)
Составить программу, которая определяет четное число или нет? Программа генерирует случайное число с помощью Rаndom и выводит само число и фразу "чётное" или "нечётное".
Ответы (1)
Написать в Паскаль программу для решения следующей задачи. Вводится строка. Написать пользовательскую функцию, которая возвращает строку 'DA', если количество символов в ней двухзначное число и возвращает 'NET', если количество символов однозначное
Ответы (1)
Расшифровать чёрный ящик: на входе 2 - на выходе 15; на входе 4 - на выходе 27 на входе 10 - на выходе 63
Ответы (1)
Написать программу в паскале! Написать программу при помощи процедуры, которая по известному радиусу возвращает в основную программу значения площади круга и длины окружности.
Ответы (1)