Задать вопрос

Составьте программу которая осуществляет ввод массив с клавы размеров 6 файлов в бaйтах от 10 до 2000 и вычисляет: 1. суммарный размер файлов в килобайтах 2. средний размер файла

+3
Ответы (1)
  1. 30 сентября, 13:15
    0
    var a: array[1 ... 6] of integer;

    i: integer;

    sum, razm: real;

    begin

    writeln ('Вводим с клавиатуры размеры файлов');

    for i : = 1 to 6 do begin

    readln (razm);

    if (razm > 10) and (razm < 2000) then a[i] : = razm else writeln ('Неправильный размер!');

    end;

    writeln ('Считаем суммарный размер в килобайтах');

    for i : = 1 to 10 do razm : = razm + a[i];

    razm : = sum / 1024;

    writeln ('Считаем средний размер файлов');

    for i : = 1 to 10 do sum : = sum + a[i];

    sum : = sum / 10;

    writeln ('Суммарный размер равен ', razm);

    writeln ('Средний размер равен ', sum);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте программу которая осуществляет ввод массив с клавы размеров 6 файлов в бaйтах от 10 до 2000 и вычисляет: 1. суммарный размер ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Составить алгоритм сложения двух целых чисел F и Q, вводимых с клавиатуры. Результат сложения записать в виде переменной W. По данному алгоритму написать программу в Паскале. алг сложение цел F, Q, W нач ввод F ввод Q W:=F+Q вывод W кон 2.
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
1. Скорость передачи данных через ADSL-соединение 128000 бит в секунду. Через данное соединение передают файл размеров 500 Кбайт. Определите время в секундах. 2. Скорость передачи данных через выделенный канал равна 512000 бит в секунду.
Ответы (1)
1) Передача данных через ADSL-соединение равна 256 000 бит/с. Передача файла через это соединение заняла 2 минуты. Определите размер файла в килобайтах. 2) Скорость передачи данных через ADSL-соединение равна 64 000 бит/с.
Ответы (1)
1) Напишите программу, которая определяет, является ли число нечётным. 2) Напишите программу, которая вычисляет сумму всех чётных чисел в диапазоне от 1 до n.
Ответы (1)