Задать вопрос

Напишите программу, которая запрашивает у пользователя число, но не больше пятизначного, и выдаёт на экран сообщение о том, сколько цифр в данном числе. 0

+3
Ответы (1)
  1. 16 ноября, 21:54
    0
    program kolichestvo_cifr;

    var n, x: integer;

    begin

    writeln ('Введите с клавиатуры число');

    readln (n);

    if x > 99999 then writeln ('Число больше пятизначного') else begin

    while n > 0 do begin

    n : = n mod 10;

    x : = x + 1;

    end;

    end;

    writeln ('В числе ', x, ' цифр');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите программу, которая запрашивает у пользователя число, но не больше пятизначного, и выдаёт на экран сообщение о том, сколько цифр в ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу, которая запрашивает четыре целых числа и выдает на экран: 1) сумму чисел; 2) сумму квадратов чисел; 3) среднее арифметическое чисел; 4) сумму парных произведений.
Ответы (1)
Составьте программу которая выводит на экран пример на умножение двух однозначных чисел, запрашивает ответ пользователя. проверяет его и выводит соответсвующиеся сообщения : "Правильно!" либо "Вы ошиблись". а также правильный результат.
Ответы (1)
Написать программу, которая запрашивает у пользователя номер товара и выводит его название (не менее 5 товаров). Если пользователь указывает недопустимое число, то выво-дится сообщение "Ошибка ввода данных"
Ответы (1)
Напишите программу в Паскале, которая запрашивает у пользователя числа до тех пор, пока каждое следующее число больше предыдущего. В конце программа сообщает, сколько чисел было введено.
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)