Задать вопрос

Нужно написать программу для решения данной задачи. В классе N учеников. После контрольной было получено: A - пятерок, B - четверок, C - двоек. Остальные - тройки. Найти процент троек.

+3
Ответы (1)
  1. 5 марта, 01:25
    0
    Программа написана на языке Паскаль:

    Program test;

    var n, a, b, c, d:integer;

    begin

    writeln ('Введите n: ');

    readln (n);

    writeln ('Введите A: ');

    readln (a);

    writeln ('Введите B: ');

    readln (b);

    writeln ('Введите C: ');

    readln (c);

    d : = n - (a+b+c);

    writeln ('Процент троек: '+d / (a+b+c) * 100);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Нужно написать программу для решения данной задачи. В классе N учеников. После контрольной было получено: A - пятерок, B - четверок, C - ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
В классе N - учеников по контрольной получили A - пятерок, B - четвёрок, C - троек. Найти процент A, B, C
Ответы (1)
В классе 30 человек. За контрольную работу по математике получено 8 пятерок, 15 четверок, 6 троек и 1 двойка. Какое количество информации в сообщении о том, что Андреев получил пятерку?
Ответы (1)
В группе 28 человек. За контрольную работу по информатике получено 7 пятерок, 12 четверок, 8 троек и 1 двойка. Какое количество информации содержится в сообщении о том, что Петров получил пятерку?
Ответы (1)
Требовалось написать программу, которая получает на входе натуральное число n и выводит число, которое получается из n после удаления всех пятерок, порядок остальных цифр при этом не меняется.
Ответы (1)
С клавиатуры вводятся числа от 1 до 9 до тех пор, пока не будет введен 0. Посчитайте количество единиц в этой последовательности, количество двоек, количество троек и так далее (программа должна вывести ровно 9 чисел).
Ответы (1)