Задать вопрос

Дана последовательность чисел а1, а2, ..., а15, упорядоченная по возрастанию, и число n1, не равное ни одному из чисел последовательности, и такое что а1

+4
Ответы (1)
  1. 29 декабря, 03:36
    0
    program zz1;

    const n = 7; / / задаем количество элементов в массиве

    A:array [1 ... n] of integer = (4, 5, 5, 6, 7, 9, 16); / / задаем последовательность чисел

    var i, k, M, n1:integer; / / задаем переменные целого типа

    begin

    writeln (' введите заданное n1');

    read (n1);

    for i:=1 to n do / / организуем цикл, в котором переберем все элементы массива

    if A[i] = n1 then k:=i; / / находим в последовательности заданное число n1 и запоминаем его номер

    for i:=1 to k-1 do / / организуем цикл до заданного числа

    M:=M + A[i]; / / вычисляем сумму

    write (' сумма последовательности чисел меньших n1 = ', M); / /выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дана последовательность чисел а1, а2, ..., а15, упорядоченная по возрастанию, и число n1, не равное ни одному из чисел последовательности, ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дана последовательность чисел, вводимых с клавиатуры и оканчивающаяся нулем. Составьте программу вычисления: a. суммы всех чисел последовательности; b. среднего арифметического всех чисел последовательности: c.
Ответы (1)
Вводится последовательность целых чисел, оканчивающаяся нулем. Число 0 в последовательность не входит. Выведите элементы последовательности в обратном порядке. Для хранения данных используйте стек.
Ответы (1)
Дана непустая последовательность целых чисел, оканчивающаяся нулем (0 является признаком окончания последовательности и в последовательность не входит). Найти и напечатать: 1. Сумму всех чисел, больших Х (значение Х вводится с клавиатуры).
Ответы (1)
Дана последовательность из n целых чисел. Определить, есть ли в ней число, равное первому из этой последовательности.
Ответы (1)
Дана непустая последовательность чисел оканчивающаяся нулем. Найти: а) сумму всех чисел последовательности, б) кол-во всех чисел последовательности. решить через Pascal ABC через repeat, for или while
Ответы (1)