Задать вопрос

С клавиатуры вводятся числа до тех пор пока не введено 5. Найти колличество четных чисел из введенных.

+1
Ответы (1)
  1. 11 мая, 22:41
    0
    var

    a, i : integer; / / объявляем переменные целочисленного типа.

    begin

    writeln ('введите последовательность чисел, окончание ввода - число 5:');

    while a 5 do / / начало цикла.

    begin

    readln (a); / / считываем число, введенное с клавиатуры.

    if (a mod 2 = 0) then / / проверяем четность текущего числа.

    i : = i + 1; / / считаем количество четных чисел.

    end;

    writeln ('Количество четных чисел в последовательности равно: ', i); / / вывод строки на экран.

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «С клавиатуры вводятся числа до тех пор пока не введено 5. Найти колличество четных чисел из введенных. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)
Напишите программу, которая вводит с клавиатуры числа до тех пор, пока не будет введено число 0. В конце работы программы на экран выводится минимальное и максимальное из введенных чисел (не считая 0)
Ответы (1)
С клавиатуры вводятся числа, пока не будет введено отрицательное число. Подсчитать количество чисел. (решение ниже) Var a, b: Integer; BEGIN While b>=0 do begin Readln (b); Inc (a); end; Writeln ('Кол-во введенных чисел : ', a-1); END.
Ответы (1)
Вычислить произведение целых чисел введенных с клавиатуры. Произведение подсчитывается до тех пор, пока вводятся числа в интервале от - 10 до + 10 через repeat ... until
Ответы (1)
С клавиатуры вводятся целые числа до тех пор пока не введенно трехзначное число. Найдите сумму введенных чисел, кроме последнего. Paskal.
Ответы (1)