Задать вопрос
7 июля, 09:25

Вычислить произведение целых чисел введенных с клавиатуры. Произведение подсчитывается до тех пор, пока вводятся числа в интервале от - 10 до + 10 через repeat ... until

+1
Ответы (1)
  1. 7 июля, 09:34
    0
    program product;

    var p, n, k: integer;

    begin

    p : = 1;

    k : = 1;

    writeln ('Для вывода результата введите множитель >10');

    writeln ();

    repeat

    write ('Введите множитель ', k, ' - - ');

    readln (n);

    if ((n - 11)) then p : = p * n;

    k : = k + 1

    until ((n > 10) or (n < - 10));

    writeln ('Произведение введенных множителей = ', p)

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Вычислить произведение целых чисел введенных с клавиатуры. Произведение подсчитывается до тех пор, пока вводятся числа в интервале от - 10 ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)
1) Найти сумму нечетных чисел на интервале [-30; 40]. 2) Найти кол-во чисел на интервале [-50; 120], которые кратны 9. 3) Найти произведение чисел кратных 11 на интервале [-10; 20]. 4) Последовательно вводятся N чисел. Найти их произведение.
Ответы (1)
С клавиатуры вводятся числа до тех пор пока не введено 5. Найти колличество четных чисел из введенных.
Ответы (1)
С клавиатуры вводятся целые числа до тех пор пока не введенно трехзначное число. Найдите сумму введенных чисел, кроме последнего. Paskal.
Ответы (1)
Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы.
Ответы (1)