Задать вопрос

С клавиатуры вводятся целые числа до тех пор пока не введенно трехзначное число. Найдите сумму введенных чисел, кроме последнего. Paskal.

+5
Ответы (1)
  1. 29 мая, 14:57
    0
    program sum_n_3;

    var n, s:integer;

    begin

    n: = 0; s: = 0;

    //Если суммироваться должны только двузначные числа

    //то условие можно изменить на while (n<100).

    //В приведенном ниже варианте суммируются все

    //числа кроме трехзначных

    while (abs (n) 999) do

    begin

    s: = s + n;

    write ('Введите число ');

    readln (n);

    end;

    writeln (s)

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «С клавиатуры вводятся целые числа до тех пор пока не введенно трехзначное число. Найдите сумму введенных чисел, кроме последнего. Paskal. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)
С клавиатуры вводятся числа до тех пор пока не введено 5. Найти колличество четных чисел из введенных.
Ответы (1)
Вычислить произведение целых чисел введенных с клавиатуры. Произведение подсчитывается до тех пор, пока вводятся числа в интервале от - 10 до + 10 через repeat ... until
Ответы (1)
С клавиатуры вводятся числа от 1 до 9 до тех пор, пока не будет введен 0. Посчитайте количество единиц в этой последовательности, количество двоек, количество троек и так далее (программа должна вывести ровно 9 чисел).
Ответы (1)
Написать программу: c клавиатуры последовательно вводятся числа, пока не введут 0. Вывести на экран количество положительных и отрицательных чисел, введенных с клавиатуры.
Ответы (1)