Задать вопрос

Написать функцию "ЕСЛИ" для расчёта оплаты электроэнергии. За первые 100 кВт клиент платит 2 руб за 1 кВт, за превышение расхода свыше 100 кВт в месяц-по2,5 руб за каждый кВт

+1
Ответы (1)
  1. 12 мая, 04:24
    0
    program e_power;

    const c1=2; c2=2.5;

    var s, w:real;

    begin

    write ('Введите расход электроэнергии в кВт*ч: ');

    Readln (w);

    if w < = 100 then

    writeln ('Стоимость электроэнергии: ', w, ' * ', c1, ' = ', w * c1, ' р.')

    else

    begin

    write ('Стоимость электроэнергии: ', 100, ' * ', c1, ' + ', (w - 100), ' * ', c2);

    writeln (' = ', 100 * c1 + (w - 100) * c2, ' р.')

    end

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать функцию "ЕСЛИ" для расчёта оплаты электроэнергии. За первые 100 кВт клиент платит 2 руб за 1 кВт, за превышение расхода свыше 100 ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Какие из перечисленных функций выполняет защитный комплекс ESET NOD32 Smart Security? Вариант 1 функцию веб-браузера Вариант 2 функцию организации родительского контроля Вариант 3 функцию антивируса Вариант 4 функцию программы для обмена
Ответы (1)
Автомат по продаже билетов принимает купюры достоинством 10 руб, 50 руб, 100 руб, но требует оплаты без сдачи. Билет стоит 130 руб. Какое минимальное количество билетов может купить пассажир, потратив 10 банкнот?
Ответы (1)
Составить программу, решающую следующую задачу: Клиент внес в банк R рублей. Каждый месяц эта сумма увеличивается на W рублей. Сколько будет у клиента денег через три месяца?
Ответы (1)
Гражданин 1 марта открыл счет в банке, вложив 1000 руб. Через каждый месяц размер вклада увеличивается на 2% от имеющейся суммы. Определить: за какой месяц величина ежемесячного увеличения вклада превысит 30 руб.
Ответы (1)
Что характерно для технологии "клиент-сервер"? Выберите один или несколько ответов:a. сервер посылает запрос клиенту и получает результатыb. основную работу выполняет компьютер-клиентc. основные данные хранятся на сервереd.
Ответы (1)