Задать вопрос
29 января, 01:02

Ввести с консоли строку символов произвольной длины (до 80 символов). Поменять в ней все маленькие символы 'a' и 'b' на заглавные и вывести на консоль полученную строку.

+5
Ответы (1)
  1. 29 января, 04:15
    0
    program zz1;

    var s:string; / / задаем переменную строкового типа

    i:integer; / / задаем переменную целого типа

    begin

    write (' введите строку ');

    read (s); / / вводим с клавиатуры строку

    for i:=1 to length (s) do / / организуем цикл, в котором переберем все символы от первого до последнего

    begin

    if s[i] = 'a' then begin delete (s, i, 1); insert ('A', s, i); end; / / производим первую замену

    if s[i] = 'b' then begin delete (s, i, 1); insert ('B', s, i); end; / / производим вторую замену

    end;

    write ('полученная строка = ', s);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Ввести с консоли строку символов произвольной длины (до 80 символов). Поменять в ней все маленькие символы 'a' и 'b' на заглавные и вывести ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Ввести 2 числа используя оператор ввода данных read (). Перед оператором read () обязательно вывести объяснения значения какой переменной надо ввести (Например, writeln ('vvedite a'); ). Ввести их через запятую.
Ответы (1)
1) Вывести массив A (N). Вывести на печать данные о числе нулевых элементов массива и их номера. Если таковых нет, вывести на печать сообщение об этом 2) Вывести массив А (N, N). Разделить все его элементы на минимальный элемент главной диагонали.
Ответы (1)
Ввести число от 5 до 9. Вывести его значение словом. Составить программу для решения приведенного ниже задания двумя способами, используя: а) команду выбора case; б) команду if. Ввести число от 5 до 9. Вывести его значение словом.
Ответы (1)
ввести 3 стороны треугольника, вывести его площадь. (на языке паскаль) ввести число, вывести квалратный корень.
Ответы (1)