Задать вопрос

Напишите программу, которая находит среднее из трёх введённых чисел. Предполагается, что все три числа различные.

+2
Ответы (1)
  1. 25 октября, 00:25
    0
    Напишем программу, которая будет находить среднее из трёх введённых чисел:

    program 2;

    var x, y, z: integer;

    begin

    writeln ('Введите три различных между собой целых числа x, y и z');

    readln (x, y, z);

    if x > y and x < z then

    writeln ('Среднее значение = ', x);

    else

    if x z then

    writeln ('Среднее значение = ', x);

    else

    if y z then

    writeln ('Среднее значение = ', y);

    else

    if y > x and y < z then

    writeln ('Среднее значение = ', y);

    else

    if z y then

    writeln ('Среднее значение = ', z);

    else

    if z > x and z < y then

    writeln ('Среднее значение = ', z);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите программу, которая находит среднее из трёх введённых чисел. Предполагается, что все три числа различные. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы.
Ответы (1)
Напишите программу, которая находит количество чисел, кратных 3, но не кратных 6, в последовательности целых чисел, вводимых клавиатуры. Признак конца ввода чисел 0. Количество введенных чисел заранее неизвестно.
Ответы (1)
1. Напишите программу, которая находит количество чисел, кратных 3, но не кратных 6, в последовательности целых чисел.
Ответы (1)
1) Напишите программу, которая определяет, является ли число нечётным. 2) Напишите программу, которая вычисляет сумму всех чётных чисел в диапазоне от 1 до n.
Ответы (1)
Составьте программу, которая находит большее из двух введенных с клавиатуры чисел a и b и выводит их на экран
Ответы (1)