Задать вопрос

Дан номер года. Определить количество дней в этом году, если високосный год делится на 4, за исключением тех годов, которые делятся на 100 и не делятся на 400. Решить нужно с помощью case.

+3
Ответы (1)
  1. 2 февраля, 21:48
    0
    program zz1;

    var p:integer; / / задаем переменную целого типа

    i:boolean; / / задаем переменную логического типа

    begin

    writeln (' Введите номер года '); / / вводим номер года с клавиатуры

    read (p);

    i: = (p mod 4 = 0) and (p mod 100 0) and (p mod 400 0); / / записываем результат проверки всех условий на високосный год в переменную

    case i of

    true:write (' Этот год високосный '); / / если условие верно, то выводим один ответ

    else write (' Этот год не високосный '); / / если условие неверно, то выводим другой ответ

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан номер года. Определить количество дней в этом году, если високосный год делится на 4, за исключением тех годов, которые делятся на 100 ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Ввести номер месяца и вывести количество дней в нем, а также число ошибок при вводе введите номер месяца: - 2 введите номер месяца: 2 введите номер месяца: 11 в этом месяце 28 дней в этом месяце 30 дней Вы вводили неверно 1 раз Вы вводили неверно 1
Ответы (1)
Задача. Год является високосным, если его номер кратен 4, однако из кратных 100 високосными являются лишь кратные 400. Например 1700,1800,1900-не високосные, а 2000 високосный. Дано натуральное число n.
Ответы (1)
Составить программу, которая в зависимости от порядкового номера месяца выводит на экран количество дней в этом месяце. Рассмотреть два случая: 1. год високосный. 2. год не является високосным
Ответы (1)
Решите одно из предложенных, умоляю дан массив А5 найти сумму и количество положительных элементов дан массив А5 определить количество отрицательных элементов дан массив А6 определить количество положительных элементов
Ответы (1)
Написать программу: Дан номер некоторого года (целое положительное число>1000). Определить соответствующий ему номер столетия, учитывая, что, к примеру, началом 20 столетия был 1901 год
Ответы (1)