Задать вопрос
28 марта, 09:15

Составить функцию, которая определяет сумму всех чисел от 1 до N

+4
Ответы (1)
  1. 28 марта, 09:51
    0
    С радостью помогу Вам, пример приведу на паскале.

    Такие штуки / / / нужно убрать, это как бы комментарий.

    program my;

    var a, b, c, d: integer; / / / (Введем четыре переменные a, b, c, d это будут числа)

    begin

    writeln ('Введите число N и программа определит сумму чисел от 1 до N');

    write ('N=');

    read (a); / / / (Вводим число а например 10)

    b:=a div 2; / / / (b=10:2=5, разбиваем на пары их у нас 5)

    c:=b*a; / / / (Количество пар умножаем на число N то есть 10, 5*10=50)

    d:=b+c; / / / (И наконец сложим число пар с числом из предыдущего действия 5+50=55)

    writeln ('Сумма чисел от 1 до ', a,' равна ', d);

    // / (Вывод результата дает 55 и это правильный ответ)

    end.

    Ниже программа без комментариев.

    program my;

    var a, b, c, d: integer;

    begin

    writeln ('Введите число N и программа определит сумму чисел от 1 до N');

    write ('N=');

    read (a);

    b:=a div 2;

    c:=b*a;

    d:=b+c;

    writeln ('Сумма чисел от 1 до ', a,' равна ', d);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить функцию, которая определяет сумму всех чисел от 1 до N ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу, которая в последовательности из 10 натуральных чисел определяет сумму чисел определяет сумму чисел, кратных 5. в последовательности всегда имеется число, кратное 5 программа должна вывести одно число сумму чисел кратных 5
Ответы (1)
1. напишите программу которая в последовательности натуральных чисел определяет сумму чисел кратных семи и оканчивающихся на один количество не известно 2.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 4.
Ответы (1)
1) Напишите программу, которая определяет, является ли число нечётным. 2) Напишите программу, которая вычисляет сумму всех чётных чисел в диапазоне от 1 до n.
Ответы (1)
Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих 256.
Ответы (1)