Задать вопрос

Вывести числа, кратные 3 в интервале от а до b (вводятся с клавиатуры). Напишите программу в Pascal

+3
Ответы (1)
  1. 3 апреля, 04:52
    0
    program a_b_3;

    var a, b: integer;

    begin

    writeln ('Введите число a');

    readln (a); / /нижняя граница диапазона

    writeln ('Введите число b');

    readln (b); / /верхняя граница диапазона

    writeln ('Числа кратные трем в интервале от ', a, ' до ', b, ':');

    for i:integer : = a to b do

    if (i mod 3) = 0 then write (i, ' ')

    / / если остаток от деления значения переменной i на 3 равен 0

    / / то печатать значение переменной i

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Вывести числа, кратные 3 в интервале от а до b (вводятся с клавиатуры). Напишите программу в Pascal ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)
1) Найти сумму нечетных чисел на интервале [-30; 40]. 2) Найти кол-во чисел на интервале [-50; 120], которые кратны 9. 3) Найти произведение чисел кратных 11 на интервале [-10; 20]. 4) Последовательно вводятся N чисел. Найти их произведение.
Ответы (1)
Написать программу: c клавиатуры последовательно вводятся числа, пока не введут 0. Вывести на экран количество положительных и отрицательных чисел, введенных с клавиатуры.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)