Задать вопрос

составить программу для вычисления длинны окружности и ее диаметра.

+4
Ответы (1)
  1. 16 ноября, 01:58
    0
    program zz1;

    var

    L, d, r : real; / / задаем переменные не целого типа

    begin

    write ('введите радиус окружности '); / / вводим с клавиатуры исходный радиус окружности

    read (r);

    d:=2 * r; / / вычисляем диаметр окружности по формуле

    writeln (' диаметр окружности = ', d:5:2); / / выводим ответ, пять знаков для всего числа и два знака после точки

    L:=Pi * d; / / вычисляем длину окружности по формуле

    write (' длина окружности = ', L:5:2); / / выводим ответ, пять знаков для всего числа и два знака после точки

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «составить программу для вычисления длинны окружности и ее диаметра. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Составить программу для вычисления площади треугольника с координатами вершин (x1, y1), (x2, y2), (x3, y3), используя формулу для вычисления расстояния между двумя точками на плоскости. Площадь вычисляется по формуле Герона
Ответы (1)
Написать программу в паскале! Написать программу при помощи процедуры, которая по известному радиусу возвращает в основную программу значения площади круга и длины окружности.
Ответы (1)
1. Составить программу для нахождения площади трапеции. 2. Составить программу для нахождения квадрата суммы двух чисел (по формулам сокращённого умножения). 3.
Ответы (1)
Дан радиус окружности. Составьте программу для вычисления длины окружности и площади круга.
Ответы (1)