Задать вопрос

Дано 4 числа найти сумму чисел, извлечь количество сотен, если четное, то найти среднее этих чисел, а, если нет, то произведение

+2
Ответы (1)
  1. 22 октября, 10:11
    0
    program zz1;

    var a, b, c, d, s, k:integer; / / задаем переменные целого типа

    begin

    write (' введите первое число '); / / вводим с клавиатуры первое число

    read (a);

    write (' введите второе число '); / / вводим с клавиатуры второе число

    read (b);

    write (' введите третье число '); / / вводим с клавиатуры третье число

    read (c);

    write (' введите четвертое число '); / / вводим с клавиатуры четвертое число

    read (d);

    s: = a + b + c + d;

    writeln (' сумма чисел = ', s);

    k: = (s mod 1000) div 100;

    write (' количество сотен = ', k);

    if k mod 2 = 0 then write (' среднее чисел = ', (a+b+c+d) / 4)

    else write (' произведение чисел = ', a*b*c*d);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дано 4 числа найти сумму чисел, извлечь количество сотен, если четное, то найти среднее этих чисел, а, если нет, то произведение ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы.
Ответы (1)
1. Дано двузначное число. Найти разность и частное его цифр. 2. Дано целое число. Если оно является положительным то прибавить к нему 1. Емли нулевым то заменить его на 10. 3. Дано двузначное число. Вывести его левую цифру, потом правую. 4.
Ответы (1)
Составить программу, которая определяет четное число или нет? Программа генерирует случайное число с помощью Rаndom и выводит само число и фразу "чётное" или "нечётное".
Ответы (1)
Дано n натуральное. найти и вывести все числа в интервале от 1 до n-1, у которых произведение всех цифр совпадает с суммой цифр данного числа. Если таких чисел нет вывести "Нет". Паскаль
Ответы (1)