Задать вопрос

Дано слово из 12 букв. Поменять местами его трети следующим образом: первую треть слова разместить на месте третьей, вторую треть на месте первой, третью треть на месте второй.

+2
Ответы (1)
  1. 31 июля, 18:07
    0
    program 1

    var s, s1, s2, s3:string;

    i, h:integer;

    begin

    write ('S=');

    read (s);

    h:=length (s) div 3;

    for i:=1 to h do

    s1:=s1+s[i];

    for i:=h+1 to h*2 do

    s2:=s2+s[i];

    for i:=h*2+1 to h*3 do

    s3:=s3+s[i];

    writeln ('S=', s2, s3, s1);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дано слово из 12 букв. Поменять местами его трети следующим образом: первую треть слова разместить на месте третьей, вторую треть на месте ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Ан массив целых чисел n=14 заполненный случайным образом числами из промежутка [-15 30] 1) удалить последний четный элемент 2) поменять местами первую и вторую его половины.
Ответы (1)
72 шаров разложили на три попарно неравные кучки. Если из первой кучки переложить во вторую столько шаров, сколько в этой второй кучке было, затем из второй в третью переложить столько, сколько в этой третьей перед тем будет находиться, и из третьей
Ответы (1)
48 шаров разложили на три попарно неравные кучки. Если из первой кучки переложить во вторую столько шаров, сколько в этой второй кучке было, затем из второй в третью переложить столько, сколько в этой третьей перед тем будет находиться, и из третьей
Ответы (2)
написать программу в паскале Из диапазона от 10 до 1000 компьютер выбрал случайным образом число. Если выбранное число является трехзначным, то поменять местами первую и последнюю цифры, выдать на печать число, выбранное ПК и новое, полученное после
Ответы (1)
Даны числа 3, 7, 1, 6, 2, 4, 8, 5. Разрешается поменять два любых числа в этом списке. Например, если поменять местами числа 6 и 8, то получится список 3, 7, 1, 8, 2, 4, 6, 5.
Ответы (1)