Задать вопрос
30 сентября, 07:10

Дана последовательность целых чисел x1 x2 xn и натуральное n получить последовательность чисел кратных 3 и не кратных 5

+3
Ответы (1)
  1. 30 сентября, 09:41
    0
    program zz1;

    const n = 7; / / задаем количество элементов в массиве

    R:array [1 ... n] of integer = (4, - 15, 15, 6, - 7, 9, - 6); / / задаем последовательность чисел

    var i:integer; / / задаем переменные целого типа

    begin

    write (' элементы кратные трем и не кратные пяти ');

    for i:=1 to n do / / организуем цикл, в котором переберем все элементы массива

    begin

    if (R[i] mod 3 = 0) and (R[i] mod 5 0) then / / проверяем, если элемент массива делится на три и не делится на пять, то

    write (R[i], ' '); / / выводим ответ

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дана последовательность целых чисел x1 x2 xn и натуральное n получить последовательность чисел кратных 3 и не кратных 5 ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Напишите программу, которая находит количество чисел, кратных 3, но не кратных 6, в последовательности целых чисел.
Ответы (1)
1. Дан массив натуральных чисел. Найти сумму элементов кратных данному К. 2. В целочисленной последовательности есть нулевые элементы. Создать массив из номеров этих элементов. 3. дана последовательность целых чисел а1, а2, ... аn.
Ответы (1)
Дана непустая последовательность целых чисел, оканчивающаяся нулем (0 является признаком окончания последовательности и в последовательность не входит). Найти и напечатать: 1. Сумму всех чисел, больших Х (значение Х вводится с клавиатуры).
Ответы (1)
Напишите программу, которая находит количество чисел, кратных 3, но не кратных 6, в последовательности целых чисел, вводимых клавиатуры. Признак конца ввода чисел 0. Количество введенных чисел заранее неизвестно.
Ответы (1)
Дана последовательность натуральных чисел, окончанием последовательности число 0. составить программу, котрая вычисляет сумму и среднее арифмитическое чисел кратных 3
Ответы (1)