Задать вопрос

Написать программу pascal: найти сумму всех чисел с клавиатуры, кратных заданному числу a.

+2
Ответы (1)
  1. 23 августа, 16:01
    0
    program zz1;

    var a, b, n, i, m: integer; / / задаем переменные целого типа

    begin

    write (' введите сколько чисел будем вводить '); / / вводим с клавиатуры число

    read (n);

    write (' введите заданное число а '); / / вводим с клавиатуры число

    read (a);

    for i:=1 to n do

    begin

    read (b); / / вводим число

    if b mod a = 0 then m: = m + b; / / проверяем, если число делится на заданное без остатка, то добавляем его в сумму

    end;

    write (' сумма всех чисел с клавиатуры, кратных заданному числу a = ', m); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу pascal: найти сумму всех чисел с клавиатуры, кратных заданному числу a. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Напишите программу, которая находит количество чисел, кратных 3, но не кратных 6, в последовательности целых чисел.
Ответы (1)
Напишите программу, которая в последовательности из 10 натуральных чисел определяет сумму чисел определяет сумму чисел, кратных 5. в последовательности всегда имеется число, кратное 5 программа должна вывести одно число сумму чисел кратных 5
Ответы (1)
Напишите программу, которая находит количество чисел, кратных 3, но не кратных 6, в последовательности целых чисел, вводимых клавиатуры. Признак конца ввода чисел 0. Количество введенных чисел заранее неизвестно.
Ответы (1)
Составить программу в Pascal 1) в строке, введенной с клавиатуры, все буквы И заменить на % 2) из строки, введенной с клавиатуры, удалить все символы, начиная с середины.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)