Задать вопрос

Дана последовательность из n целых чисел. Найти среднее арифметическое этой последовательности.

+1
Ответы (1)
  1. 12 ноября, 05:01
    0
    program zz1;

    const n = 13; / / задаем количество элементов в последовательности

    R:array [1 ... n] of integer = (26, - 53, 0, - 67, 12, - 34, 0, 90, 14, - 78, 0, - 45, 66); / / задаем последовательность чисел

    var i, k, m:integer; / / задаем переменные целого типа

    begin

    for i:=1 to n do / / организуем цикл, в котором переберем все числа в последовательности

    m:=m + R[i]; / / добавляем элемент последовательности в сумму

    writeln (' среднее арифметическое значение чисел в последовательности = ', m/n); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дана последовательность из n целых чисел. Найти среднее арифметическое этой последовательности. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Определите среднее арифметическое элементов последовательности, завершающейся числом 0. Число 0 в последовательность не входит. Числа, следующие за нулем, считывать не нужно. Входные данные Вводится последовательность целых чисел.
Ответы (1)
Дана непустая последовательность целых чисел, оканчивающаяся нулем (0 является признаком окончания последовательности и в последовательность не входит). Найти и напечатать: 1. Сумму всех чисел, больших Х (значение Х вводится с клавиатуры).
Ответы (1)
Вводится последовательность целых чисел, оканчивающаяся нулем. Число 0 в последовательность не входит. Выведите элементы последовательности в обратном порядке. Для хранения данных используйте стек.
Ответы (1)
Дана последовательность чисел, вводимых с клавиатуры и оканчивающаяся нулем. Составьте программу вычисления: a. суммы всех чисел последовательности; b. среднего арифметического всех чисел последовательности: c.
Ответы (1)
Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы.
Ответы (1)