Задать вопрос

2. Даны два действительных числа. Заменить первое число нулем, если оно меньше или равно второму, и оставить числа без изменения в противном случае.

+4
Ответы (1)
  1. 24 ноября, 19:32
    0
    var y, r:real; {описываем две переменные действительного типа} begin {старт алгоритма} read (y); {считывание входящих данных} read (r); if y<=r then y:=0; {сравниваем числа оператором 'if', если первое число меньше - тогда присваиваем ему значение "0"} writeln (y,' ', r); {вывод результата через пробел} end. {конец работы алгоритма}
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «2. Даны два действительных числа. Заменить первое число нулем, если оно меньше или равно второму, и оставить числа без изменения в ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Даны действительные числа a и b если а
Ответы (1)
Обозначим символом Z бит, определяющий факт равенства результата R нулю, а символом N - бит, фиксирующий отрицательность R: Z = 1 при R = 0, иZ=0 в противном случае; N = 1 при ЯR О, и 0 в противном случае.
Ответы (1)
Написать программу паскале: Даны два числа. Увеличить каждое из них в два раза, если их сумма четная, в противном случае увеличить в два раза только первое число.
Ответы (1)
Даны действительные числа x, y, z Если все числа положительны, увеличить их значения в 2 раза; во всех отальных случаях отрицательные числа заменить их модулями, а положительные оставить без изменения. (Надо написать программу на паскале)
Ответы (1)
С# даны три переменные: x, y, z (входные данные). если их значения упорядочены по убыванию, то удвоить их. в противном случае заменить значение каждой переменной на противоположное.
Ответы (1)