Задать вопрос
28 августа, 23:22

Написать алгоритм для паскаля. Даны целые числа a и b. Определить остаток от деления a на b, не используя стандартную операцию вычисления остатка

+2
Ответы (1)
  1. 29 августа, 00:53
    0
    program zz1;

    var a, b:integer; / / вводим переменные целого типа

    begin

    write (' введите первое заданное число '); / / вводим с клавиатуры первое число

    read (a);

    write (' введите второе заданное число '); / / вводим с клавиатуры второе число

    read (b);

    while a > = b do / / организуем цикл, пока первое число больше второго

    a:=a - b; / / уменьшаем первое число на второе

    write (' остаток от деления a на b, не используя стандартную операцию вычисления остатка = ', a); / / то что осталось в переменной а, выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать алгоритм для паскаля. Даны целые числа a и b. Определить остаток от деления a на b, не используя стандартную операцию вычисления ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Составить программу, которая находит минимальное натуральное число х, такое, что остаток от деления х на 10 равен 9, остаток от деления х на 9 равен 8, остаток от деления х на 8 равен 7, ... остаток от деления х на 2 равен 1.
Ответы (1)
Даны целые положительные числа N и K. Используя только операции сложения и вычитания, найти частное от деления нацело N на K, а также остаток от этого деления.
Ответы (1)
Запишите алгоритм вычисления для заданного количества суток (tfh) количества часов (Л), минут (т) и секунд (с). Выполните вычисления для заданных значений переменной tfh. Алгоритм: tfh 1 2 1/2 h т с
Ответы (1)
Написать алгоритм: Даны 2 числа a и b оба вводятся с клавиатуры, написать алгоритм нахождения наибольшего из них
Ответы (1)
Написать алгоритм для паскаля. Составить программу, которая после введённого с клавиатуры числа от 1 до 99 обозначает денежную единицу дописывающую слово "копейка" в правильной форме.
Ответы (1)