Задать вопрос

Написать алгоритм для паскаля. Составить программу, которая после введённого с клавиатуры числа от 1 до 99 обозначает денежную единицу дописывающую слово "копейка" в правильной форме.

+3
Ответы (1)
  1. 5 декабря, 06:54
    0
    program zz1;

    var a, b:integer; / / вводим переменные целого типа

    begin

    write (' введите число '); / / вводим с клавиатуры число

    read (a);

    if a mod 10 = 1 then write (a, ' копейка ');

    if ((a > 19) or (a < 11)) and ((a mod 10 = 2) or (a mod 10 = 3) or (a mod 10 = 4)) then write (a,' копейки ');

    if ((a > 19) or (a < 11)) and ((a mod 10 = 5) or (a mod 10 = 6) or (a mod 10 = 7) or (a mod 10 = 8) or (a mod 10 = 9) or (a mod 10 = 0)) then write (a,' копеек ');

    if (a > 11) and (a < 20) then write (a,' копеек ');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать алгоритм для паскаля. Составить программу, которая после введённого с клавиатуры числа от 1 до 99 обозначает денежную единицу ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы