Задать вопрос

Написать алгоритм вычисления по формуле y = (1-x²+2,5³x+x) ² третий x в четвертой степени. не нашел маленькой четверки. Учитывая ограничения 1) Пользоваться можно только сложением, вычитанием, и умножением 2) каждое выражение может содержать только 1 арифметическую операцию.

+4
Ответы (1)
  1. 6 декабря, 14:23
    0
    program zz1;

    var a, b, c, d, e, f, g, x, y:real; / / задаем переменные не целого типа

    begin

    write (' введите x '); / / вводим с клавиатуры число

    read (x);

    a:=x * x; / / вычисляем первое выражение

    b:=1 - a; / / вычисляем второе выражение

    c:=a * x; / / вычисляем третье выражение

    d:=2.5 * c; / / вычисляем четвертое выражение

    e:=b + d; / / вычисляем пятое выражение

    f:=a * a; / / вычисляем шестое выражение

    g:=e + f; / / вычисляем седьмое выражение

    y:=g * g; / / вычисляем восьмое выражение

    writeln (' полученный результат = ', y); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать алгоритм вычисления по формуле y = (1-x²+2,5³x+x) ² третий x в четвертой степени. не нашел маленькой четверки. Учитывая ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Тема: Линейные вычислительные алгоритмы. Задание: Напишите алгоритм вычисления у по формуле у = (1-x^2+5x^4) ^2 где х-заданное целое число. Учтите след. ограничения: 1) в арифм.
Ответы (1)
Написать алгоритм для паскаля. Даны целые числа a и b. Определить остаток от деления a на b, не используя стандартную операцию вычисления остатка
Ответы (1)
Что такое алгоритм? Зачем люди составляют и исполняют алгоритм. Какими разными способами можно описать способ решения задач? Как называют наглядную модель процесса решения задач? Какой алгоритм можно назвать линейным?
Ответы (1)
Запишите алгоритм вычисления для заданного количества суток (tfh) количества часов (Л), минут (т) и секунд (с). Выполните вычисления для заданных значений переменной tfh. Алгоритм: tfh 1 2 1/2 h т с
Ответы (1)
Разработать алгоритм для ввода четырёх целых чисел и вычисление их среднего арифметического. Протестировать алгоритм на исходных данных: - 5,8,-1,9. Линейный алгоритм
Ответы (1)