Задать вопрос
6 декабря, 20:12

Найти среднее арифметическое трех чисел a, d, c. На языке паскаля

+2
Ответы (1)
  1. 7 декабря, 00:01
    0
    program zz1;

    var a, b, c, r:real; / / задаем переменные не целого типа

    begin

    write (' введите первое заданное число '); / / вводим с клавиатуры первое число

    read (a);

    write (' введите второе заданное число '); / / вводим с клавиатуры второе число

    read (b);

    write (' введите третье заданное число '); / / вводим с клавиатуры третье число

    read (c);

    r:=a + b + c; / / вычисляем сумму трех заданных чисел по формуле

    writeLn (' среднее арифметическое трех чисел = ', r / 3); / / выводим ответ, разделив предварительно полученную сумму на три

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Найти среднее арифметическое трех чисел a, d, c. На языке паскаля ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Составить две программы на языке Паскаля с помощью операторов цикла До и Пока, которые будут вводить целые числа (до тех пор, пока не будет введен ноль), подсчитывать сумму и среднее арифметическое введеных положительных чисел.
Ответы (1)
На языке Паскаля. Составе программу, которая вводится с клавиатуры последовательность из пяти висели после ввода каждого числа выводят среднее арифметическое полученной части последовательности.
Ответы (1)
Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы.
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными индексами. выведите на экран исходный массив и полученное среднее арифметическое. 2.
Ответы (1)
Дан массив из 15 чисел заполненный случайными числами из интервала [-20; 20]. определить, что больше среднее арифметическое элементов стоящих на четных местах или среднее арифметическое положительных элементов массива
Ответы (1)