Задать вопрос

Напишите программу которая по введенному числу из промежутка от 0 до 24 определяет время суток. через if и case.

+5
Ответы (1)
  1. 5 марта, 06:16
    0
    Пишем программу, которая по введенному числу из промежутка от 0 до 24 позволит нам определить время суток:

    Pascal.

    program qq;

    var a: integer;

    begin

    read (a);

    if (a > 5) and (a < = 11) then

    write ('Утро ');

    if (a > 11) and (a < = 17) then

    write ('День ');

    if (a > 17) and (a < = 23) then

    write ('Вечер');

    if (a = 24) or (a < 6) then

    write ('Ночь');

    end.

    Программа написана.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите программу которая по введенному числу из промежутка от 0 до 24 определяет время суток. через if и case. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Напишите программу, которая определяет, является ли число нечётным. 2) Напишите программу, которая вычисляет сумму всех чётных чисел в диапазоне от 1 до n.
Ответы (1)
Дано натуральное число k. Написать программу, которая по введенному числу k от 1 до 99 напишет фразу: ("Мне, k, лет")
Ответы (1)
1. напишите программу которая в последовательности натуральных чисел определяет сумму чисел кратных семи и оканчивающихся на один количество не известно 2.
Ответы (1)
Напишите программу формирования и вывода массива размером 6x3, каждые три последовательных элемента в строке которого составлены по следующему правилу: 1-й - равен удвоенному числу, введенному с клавиатуры;
Ответы (1)
Составить на Паскале программу, которая по введённому номеру месяца выводит название времени года. При написании программы использовать логические операции.
Ответы (1)